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This manual describes the functions and operating procedures of GateOPC. To ensure
correct use, please read this manual thoroughly before beginning operation. After
reading the manual, keep it in a convenient location for quick reference in the event a
question arises.

GateOPC is a software program that uses the OPC (OLE for process control) protocol to
acquire measurement data and pass that data to DAQLOGGER or Remote Monitor.

» The contents of this manual are subject to change without prior notice as a result of
improvements in the software’s performance and functions.

» Every effort has been made in the preparation of this manual to ensure the accuracy
of its contents. However, should you have any questions or find any errors, please
contact your nearest YOKOGAWA representative as listed on the back cover of this
manual.

» Copying or reproducing all or any part of the contents of this manual without the
permission of Yokogawa Electric Corporation is strictly prohibited.

» Use of this product (software and this manual) on more than one computer at the
same time is prohibited. Use by more than one user is also prohibited.

» Transfer or lending of this product to any third party is prohibited.

* Yokogawa Electric Corporation provides no guarantees other than for physical
deficiencies found on the original disk or this manual upon opening the product
package.

¢ License numbers will not be reissued. Please keep the license number in a safe
place.

» Copyrights for the programs included on the CD-ROM are attributable to Yokogawa
Electric Corporation.

+ DAQWORX, DAQLOGGER, and DAQEXPLORER are registered trademarks or
trademarks of Yokogawa Electric Corporation.

* Microsoft and Windows are registered trademarks or trademarks of Microsoft
Corporation in the United States and/or other countries.

» Adobe and Acrobat are registered trademarks or trademarks of Adobe Systems
Incorporated.

» Company and product names that appear in this manual are registered trademarks or
trademarks of their respective holders.

* The company and product names used in this manual are not accompanied by the
registered trademark or trademark symbols (® and ™).

* 1st Edition  June 2003

* 2nd Edition February 2003
* 3rd Edition  June 2007

* 4th Edition  March 2008

All Rights Reserved, Copyright © 2003 Yokogawa Electric Corporation
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Terms and Conditions of the Software License

NOTICE - PLEASE READ CAREFULLY BEFORE USE

Thank you very much for purchasing this medium containing a software program and related documentation provided by Yokogawa Electric Corporation (hereinafter called
“Yokogawa”), and the program contained, embedded, inserted or used in the medium (hereinafter called the “Yokogawa Software Program”).

By opening this package or plastic wrapping (hereinafter called “Package”) enclosing the Yokogawa Software Program, you acknowledge that you understand and agree to
the “Terms and Conditions of the Software License” (hereinafter called “Terms and Conditions”) which is written in the documentation and separately attached. Accordingly,
the Terms and Conditions bind you.

The Yokogawa Software Program and its related documentation including ownership of copyright shall remain the exclusive property of Yokogawa or those third parties from
whom sublicensed software in the Yokogawa Software Program is licensed.

Yokogawa hereby grants you permission to use the Yokogawa Software Program on the conditions that you agree to the Terms and Conditions before you open the Package
and/or install it in or onto a computer.

IF YOU DO NOT AGREE TO THE TERMS AND CONDITIONS, YOU CANNOT OPEN THE PACKAGE, AND MUST IMMEDIATELY RETURN IT TO YOKOGAWA OR ITS
DESIGNATED PARTY.

Terms and Conditions of the Software License

Yokogawa Electric Corporation, a Japanese corporation (hereinafter called “Yokogawa”), grants permission to use this Yokogawa Software Program (hereinafter called the
“Licensed Software”) to the Licensee on the conditions that the Licensee agrees to the terms and conditions stipulated in Article 1 hereof.

You, as the Licensee (hereinafter called “Licensee”), shall agree to the following terms and conditions for the software license (hereinafter called the “Agreement”) based on
the use intended for the Licensed Software.

Please note that Yokogawa grants the Licensee permission to use the Licensed Software under the terms and conditions herein and in no event shall Yokogawa intend to
sell or transfer the Licensed Software to the Licensee.

Licensed Software Name:  GateOPC (Model WX1)

Number of License: 1

Article 1 (Scope Covered by these Terms and Conditions)

1.1The terms and conditions stipulated herein shall be applied to any Licensee who purchases the Licensed Software on the condition that the Licensee consents to agree
to the terms and conditions stipulated herein.

1.2The “Licensed Software” herein shall mean and include all applicable programs and documentation, without limitation, all proprietary technology, algorithms, and know-
how such as a factor, invariant or process contained therein.

Avrticle 2 (Grant of License)

2.1Yokogawa grants the Licensee, for the purpose of single use, non-exclusive and non-transferable license of the Licensed Software with the license fee separately agreed
upon by both parties.

2.2The Licensee is, unless otherwise agreed in writing by Yokogawa, not entitled to copy, change, sell, distribute, transfer, or sublicense the Licensed Software.

2.3The Licensed Software shall not be copied in whole or in part except for keeping one (1) copy for back-up purposes. The Licensee shall secure or supervise the copy of
the Licensed Software by the Licensee itself with great, strict, and due care.

2.4In no event shall the Licensee dump, reverse assemble, reverse compile, or reverse engineer the Licensed Software so that the Licensee may translate the Licensed
Software into other programs or change it into a man-readable form from the source code of the Licensed Software. Unless otherwise separately agreed by Yokogawa,
Yokogawa shall not provide the Licensee the source code for the Licensed Software.

2.5The Licensed Software and its related documentation shall be the proprietary property or trade secret of Yokogawa or a third party which grants Yokogawa the rights. In no
event shall the Licensee be transferred, leased, sublicensed, or assigned any rights relating to the Licensed Software.

2.6Yokogawa may use or add copy protection in or onto the Licensed Software. In no event shall the Licensee remove or attempt to remove such copy protection.

2.7The Licensed Software may include a software program licensed for re-use by a third party (hereinafter called “Third Party Software”, which may include any software program
from affiliates of Yokogawa made or coded by themselves.) In the case that Yokogawa is granted permission to sublicense to third parties by any licensors (sub-licensor) of
the Third Party Software pursuant to different terms and conditions than those stipulated in this Agreement, the Licensee shall observe such terms and conditions of which
Yokogawa notifies the Licensee in writing separately.

2.8In no event shall the Licensee modify, remove or delete a copyright notice of Yokogawa and its licenser contained in the Licensed Software, including any copy thereof.

Article 3 (Restriction of Specific Use)
3.1The Licensed Software shall not be intended specifically to be designed, developed, constructed, manufactured, distributed or maintained for the purpose of the following
events:
a) Operation of any aviation, vessel, or support of those operations from the ground;,
b) Operation of nuclear products and/or facilities;,
c) Operation of nuclear weapons and/or chemical weapons and/or biological weapons; or
d) Operation of medical instrumentation directly utilized for humankind or the human body.
3.2Even if the Licensee uses the Licensed Software for the purposes in the preceding Paragraph 3.1, Yokogawa has no liability to or responsibility for any demand or damage
arising out of the use or operations of the Licensed Software, and the Licensee agrees, on its own responsibility, to solve and settle the claims and damages and to defend,
indemnify or hold Yokogawa totally harmless, from or against any liabilities, losses, damages and expenses (including fees for recalling the Products and reasonable
attorney’s fees and court costs), or claims arising out of and related to the above-said claims and damages.

Article 4 (Warranty)

4.1The Licensee shall agree that the Licensed Software shall be provided to the Licensee on an “as is” basis when delivered. If defect(s), such as damage to the medium
of the Licensed Software, attributable to Yokogawa is found, Yokogawa agrees to replace, free of charge, any Licensed Software on condition that the defective Licensed
Software shall be returned to Yokogawa'’s specified authorized service facility within seven (7) days after opening the Package at the Licensee’s expense. As the Licensed
Software is provided to the Licensee on an “as is” basis when delivered, in no event shall Yokogawa warrant that any information on or in the Licensed Software, including
without limitation, data on computer programs and program listings, be completely accurate, correct, reliable, or the most updated.

4.2Notwithstanding the preceding Paragraph 4.1, when third party software is included in the Licensed Software, the warranty period and terms and conditions that apply
shall be those established by the provider of the third party software.
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Terms and Conditions of the Software License

4.3When Yokogawa decides in its own judgement that it is necessary, Yokogawa may from time to time provide the Licensee with Revision upgrades and Version upgrades
separately specified by Yokogawa (hereinafter called “Updates”).

4.4Notwithstanding the preceding Paragraph 4.3, in no event shall Yokogawa provide Updates where the Licensee or any third party conducted renovation or improvement
of the Licensed Software.

4.5THE FOREGOING WARRANTIES ARE EXCLUSIVE AND IN LIEU OF ALL OTHER WARRANTIES OF QUALITY AND PERFORMANCE, WRITTEN, ORAL, OR
IMPLIED, AND ALL OTHER WARRANTIES INCLUDING ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE ARE
HEREBY DISCLAIMED BY YOKOGAWA AND ALL THIRD PARTIES LICENSING THIRD PARTY SOFTWARE TO YOKOGAWA.

4.6Correction of nonconformity in the manner and for the period of time provided above shall be the Licensee’s sole and exclusive remedy for any failure of Yokogawa to
comply with its obligations and shall constitute fulfillment of all liabilities of Yokogawa and any third party licensing the Third Party Software to Yokogawa (including any
liability for direct, indirect, special, incidental or consequential damages) whether in warranty, contract, tort (including negligence but excluding willful conduct or gross
negligence by Yokogawa) or otherwise with respect to or arising out of the use of the Licensed Software.

Article 5 (Infringement)
5.1If and when any third party should demand injunction, initiate a law suit, or demand compensation for damages against the Licensee under patent right (including utility
model right, design patent, and trade mark), copy right, and any other rights relating to any of the Licensed Software, the Licensee shall notify Yokogawa in writing to that
effect without delay.
5.2In the case of the preceding Paragraph 5.1, the Licensee shall assign to Yokogawa all of the rights to defend the Licensee and to negotiate with the claiming party.
Furthermore, the Licensee shall provide Yokogawa with necessary information or any other assistance for Yokogawa’s defense and negotiation. If and when such a claim
should be attributable to Yokogawa, subject to the written notice to Yokogawa stated in the preceding Paragraph 5.1, Yokogawa shall defend the Licensee and negotiate
with the claiming party at Yokogawa’s cost and expense and be responsible for the final settlement or judgment granted to the claiming party in the preceding Paragraph
5.1.
5.3When any assertion or allegation of the infringement of the third party’s rights defined in Paragraph 5.1 is made, or when at Yokogawa'’s judgment there is possibility of
such assertion or allegation, Yokogawa will, at its own discretion, take any of the following countermeasures at Yokogawa'’s cost and expense.
a) To acquire the necessary right from a third party which has lawful ownership of the right so that the Licensee will be able to continue to use the Licensed Software;
b) To replace the Licensed Software with an alternative one which avoids the infringement; or
c) To remodel the Licensed Software so that the Licensed Software can avoid the infringement of such third party’s right.
5.41f and when Yokogawa fails to take either of the countermeasures as set forth in the preceding subparagraphs of Paragraph 5.3, Yokogawa shall indemnify the Licensee
only by paying back the price amount of the Licensed Software which Yokogawa has received from the Licensee. THE FOREGOING PARAGRAPHS STATE THE
ENTIRE LIABILITY OF YOKOGAWAAND ANY THIRD PARTY LICENSING THIRD PARTY SOFTWARE TO YOKOGAWA WITH RESPECT TO INFRINGEMENT OF THE
INTELLECTUAL PROPERTY RIGHTS INCLUDING BUT NOT LIMITED TO, PATENT AND COPYRIGHT.

Article 6 (Liabilities)

6.11f and when the Licensee should incur any damage relating to or arising out of the Licensed Software or service that Yokogawa has provided to the Licensee under the
conditions herein due to a reason attributable to Yokogawa, Yokogawa shall take actions in accordance with this Agreement. However, in no event shall Yokogawa be
liable or responsible for any special, incidental, consequential and/or indirect damage, whether in contract, warranty, tort, negligence, strict liability, or otherwise, including,
without limitation, loss of operational profit or revenue, loss of use of the Licensed Software, or any associated products or equipment, cost of capital, loss or cost of
interruption of the Licensee’s business, substitute equipment, facilities or services, downtime costs, delays, and loss of business information, or claims of customers of
Licensee or other third parties for such or other damages. Even if Yokogawa is liable or responsible for the damages attributable to Yokogawa and to the extent of this
Article 6, Yokogawa'’s liability for the Licensee’s damage shall not exceed the price amount of the Licensed Software or service fee which Yokogawa has received. Please
note that Yokogawa shall be released or discharged from part or all of the liability under this Agreement if the Licensee modifies, remodels, combines with other software
or products, or causes any deviation from the basic specifications or functional specifications, without Yokogawa'’s prior written consent.

6.2All causes of action against Yokogawa arising out of or relating to this Agreement or the performance or breach hereof shall expire unless Yokogawa is notified of the claim
within one (1) year of its occurrence.

6.3In no event, regardless of cause, shall Yokogawa assume responsibility for or be liable for penalties or penalty clauses in any contracts between the Licensee and its
customers.

Article 7 (Limit of Export)
Unless otherwise agreed by Yokogawa, the Licensee shall not directly or indirectly export or transfer the Licensed Software to any countries other than those where Yokogawa
permits export in advance.

Article 8 (Term)
This Agreement shall become effective on the date when the Licensee receives the Licensed Software and continues in effect unless or until terminated as provided herein,
or the Licensee ceases using the Licensed Software by itself or with Yokogawa'’s thirty (30) days prior written notice to the Licensee.

Article 9 (Injunction for Use)
During the term of this Agreement, Yokogawa may, at its own discretion, demand injunction against the Licensee in case that Yokogawa deems that the Licensed Software is
used improperly or under severer environments other than those where Yokogawa has first approved, or any other condition which Yokogawa may not permit.

Article 10 (Termination)
Yokogawa, at its sole discretion, may terminate this Agreement without any notice or reminder to the Licensee if the Licensee violates or fails to perform this Agreement.
However, Articles 5, 6, and 11 shall survive even after the termination.

Article 11 (Jurisdiction)

Any dispute, controversies, or differences between the parties hereto as to interpretation or execution of this Agreement shall be resolved amicably through negotiation
between the parties upon the basis of mutual trust. Should the parties fail to agree within ninety (90) days after notice from one of the parties to the other, both parties hereby
irrevocably submit to the exclusive jurisdiction of the Tokyo District Court (main office) in Japan for settlement of the dispute.

Article 12 (Governing Law)
This Agreement shall be governed by and construed in accordance with the laws of Japan. The Licensee expressly agrees to waive absolutely and irrevocably and to the
fullest extent permissible under applicable law any rights against the laws of Japan which it may have pursuant to the Licensee’s local law.

Article 13 (Severability)
In the event that any provision hereof is declared or found to be illegal by any court or tribunal of competent jurisdiction, such provision shall be null and void with respect to
the jurisdiction of that court or tribunal and all the remaining provisions hereof shall remain in full force and effect.

IM WX1-04E iii



Overview of This Manual

Structure of This Manual

This user’s manual consists of the following chapters.

Chapter Title Description

1 Overview Gives an overview of the GateOPC software.
Lists the PC requirements for running GateOPC and
gives information about system configuration.

2 Operating Procedure Lists procedures for entering environment and data
acquisition interval settings, running the program, and
viewing the status display.

3 Detailed Description of Provides a detailed description of the functions of
Functions GateOPC.
Lists error messages, their causes, and their corrective
actions.
Index An alphabetical index of the manual’s contents.

Scope of This Manual
This manual provides instructions on how perform basic operations with the software
when running under Windows XP, Windows 2000, and Windows Vista. For information
regarding the basic operations of Windows, see the Windows user’s manual.

Conventions Used in This Manual
* Units
K Denotes 1024. Example: 10 KB
M Denotes 1024K.  Example: 10 MB
G Denotes 1024M.  Example: 2 GB

¢ Boldface Type
Hardware and software controls that the user manipulates such as dialog boxes,

buttons, and menu commands are often set in boldface type.

e Subheadings
On pages in chapters 1 through 3 that describe operating procedures, the following

subheadings are used to distinguish the procedure from their explanations.

This subsection contains the operating procedure used to carry out
the function described in the current section. All procedures are

written with inexperienced users in mind; experienced users may
not need to carry out all the steps.

Note Calls attention to information that is important for proper operation
of the instrument.
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Chapter 1 Overview

1.1

Features

Overview of GateOPC Functions

GateOPC is a software program that uses the OPC (OLE for process control) protocol—
Microsoft’'s data exchange technology that is supported in a wide range of industries—to
acquire measurement data and pass that data to Yokogawa’s DAQLOGGER or Remote
Monitor. Using GateOPC allows you to acquire and monitor data on DAQLOGGER or
Remote Monitor that comes from Yokogawa recorders or other companies’DCS and PLC
devices with OPC server functionality.

Yokogawa’s DAQLOGGER is a software program that allows users to open a connection
from their PC to various kinds of Yokogawa recorders (the uR, VR, DARWIN, DX, MV,
and CX) and perform data logging and monitoring.

Yokogawa’s Remote Monitor is application software that enables monitoring of data
logged by recorders or data logging software.

» Acts as an OPC client, connecting to an OPC DA (data access) server (hereinafter
OPC server).
» Can acquire data from 16 OPC servers simultaneously.
« Measurement can be performed at intervals of up to 0.5 seconds'.
* However, DAQLOGGER's shortest interval is 1 second. Also, the maximum speed of 0.5
seconds may not be attainable depending on the amount of data being read, the response
time of the device, and the communication speed.
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1.2 System Overview

System

This software can acquire data from OPC DA revision 2.0 servers or later.

Required Operating Systems
Run DAQWORX under any of the following operating systems.

Windows 2000 Professional SP4

Windows XP Home Edition SP2

Windows XP Professional SP2 (excluding Windows XP Professional x64 Edition)

Windows Vista Home Premium (excluding the 64-bit edition)

Windows Vista Business (excluding the 64-bit edition)

The language displayed by the software under different language versions of the OS are

as follows.

OS Language Software Language
Japanese Japanese

Other English

Hardware Requirements
The following hardware and software are required to use GateOPC.

PC:

Free disk space:

A PC that runs one of the OS above, and that meets the
following CPU and memory requirements.

When Using Windows 2000 or Windows XP

Pentium 4, 1.6 GHz or faster

512 MB or more of memory

When Using Windows Vista

Pentium 4, 3 GHz or faster

2GB or more of memory

200 MB or more

Communication device: An Ethernet (when connecting to DAQLOGGER or Remote

CD-ROM drive:
Peripheral devices:
GP-IB port:

Monitor:

Monitor) port that is recognized by the operating system.
Used to install the software
A mouse supported by the operating system
Required for GPIB communications between the software and
a WT series instrument
When Using Windows 2000 or Windows XP
A monitor supported by the OS of 1024 x 768 dpi or higher and
65,536 colors or more.
When Using Windows Vista
A video card recommended for use with Vista and a monitor
supported by the OS of 1024 x 768 dpi or higher and 65,536
colors or more.

1-2
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1.2 System Overview

System Configuration

e e
GateOPC

e

[z Cmesmz@ee®
e o |

Remote Monitor

OPC connection
Data transfer

PLC, DCS etc

It is recommended that you run GateOPC and DAQLOGGER or Remote Monitor on

separate PCs depending on the number of devices that the system supports and other

factors affecting the load.

Software Configuration

[ aotambe |
GateOPC
1Writes tofile Status informatio‘
File read out l

settings file

DAQLOGGER

Aernet
W\ernet

OPC interface

GateOPC Configurator consists of three separate software functions. The role of each

function within the configurator is as follows:

¢ Environment Setting Functions
These functions allow the user to enter various settings required by the executable
function for communications with OPC servers, as well as those required for data
transfers to and from DAQLOGGER and Remote Monitor. The user can also use
the environment setting functions to start/stop the executable function, or view the
execution status.

* Executable Function
The function reads data from OPC servers at fixed intervals. Up to 16 OPC servers

Remote Monitor

can be linked. It also acts as a monitor server, transferring data to DAQLOGGER and

Remote Monitor.

» Status Display Function
The execution status of the executable software can be displayed, as well as the

connection status of DAQLOGGER and Remote Monitor.

IM WX1-04E
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Chapter 2  Operating Procedure

2.1 Running and Exiting GateOPC

Running the Software

Procedure

Nofte

From the Windows Start menu, choose Programs > YOKOGAWA DAQWORX >
GateOPC > GateOPC.

The GateOPC Configurator dialog box opens.

§4 GateOPC Configurator =18lx
= r [m]

File Execute View Help

BB R » & e !”E‘?

/[ System No. [ Use OPC Server Name | Soan Intervallmses] | Rety Uss | Rety Intervallsec)
o

Delete

Ready [ I Y1

When you start GateOPC it is restored to the same status that was active during the
previous session.

If the program is closed while a process or service is running, the license will be considered
to be “in use.” If the message, “Invalid license number. Please reinstall.” appears when
restarting the program, it may indicate that the user is attempting to run a Gate program in
excess of the number of available licenses.

Starting GateMX/MW in Acquisition Start Mode

Procedure

Exiting the Software

Procedure

From the Windows Start menu, choose Programs > YOKOGAWA DAQWORX >
GateOPC > GateOPC, then right-click GateOPC and select Create Shortcut.
Right-click the shortcut icon and select Properties.

Choose the Shortcut tab, then add /START to the right of the path in the Target
box and click OK.

GateOPC Properties ﬂll

General  Shortcut | Eompatibilityl

@ GateOPC
Ed

Target type: Application

Target location: GateOPC

Target: IW’D R=h\GateOPCAWG ateOPCConfigE . exe /START

Choose the shortcut from the Windows Start menu. The connection status of the
previous session is restored, and acquisition begins.

Choose File > Exit from the menu bar, or click the X button at the right end of
the title bar.

GateOPC closes.

IM WX1-04E
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2.2 Entering Environment Settings

When you start GateOPC, the configurator opens allowing you to perform the following:

Specify an OPC server

Connect to an OPC server

Edit an OPC server item

Create/delete groups

Add/delete group items

Set item properties

Test acquisition

Run/stop the executable function (see section 2.3)

Enter TCP/IP port numbers for monitor servers (see section 2.3)

Specifying an OPC Server

Procedure

1. Click the Addition of an OPC server button or choose File > Addition of an OPC
server from the menu bar.

The Addition of an OPC server button

The Select OPC Server dialog box opens.

OPCServer LI
Computer @ Local ¢ Remote

Computer Name | _{—Browse button
PraglD Search | [T Lozal

T akebishi.FA 3.1
TakebishiMelsec.

System No [t s}—————Click to display a list and
select a system number
ok | CANCEL |

2. Enter settings for each item.
Computer: Select either Local or Remote.
Computer Name: Specify if you selected a remote computer. Enter the name of
the computer when using DCOM. Click Browse to open the
Browse Computers dialog box. Select a computer.
Browse for Computer el S

Find computer

Mebwork Places
Entire Metwork
% Computers Mear Me

[#]- Fald

(6] 4 Cancel
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2.2 Entering Environment Settings

ProgID: Click the Search button to display the ProglID list, then make a
selection.

If Local was selected above, the software searches for an OPC
server on the local computer, then displays the results.

If you selected Remote above, the software searches for a
remote computer having the specified name, then searches
that computer for an OPC server. Up to 80 characters can be
entered for a computer name. However, if Local was selected,
the ProglID of the local computer is displayed.

System No: Select the system number to assign to the OPC server. You
can display the OPC server list (see “Browsing OPC Server
Items” in chapter 3) to see which OPC servers are assigned to
which systems.

Up to 16 OPC servers can be connected.
3. Click OK.

A list showing system numbers assigned to OPC servers is shown in the bottom
of the GateOPCConfiguration screen.

Connecting/Disconnecting OPC Servers
Connecting to Servers
1. Click the Connection button or choose File > Connection from the menu bar.

Connection button

A connection is opened with all active OPC servers.

Notfte

If the connection to an OPC server is cut, the causes may include the following:
» The software disconnected from the OPC server (see “Disconnecting from the Servers”
below).

» The connection was cut due to the execution of a process or service.
» The connection was cut due to a problem on the OPC server.

Disconnecting from Servers
1. Choose File > Disconnection from the menu bar.

Connections with the active OPC servers are closed.

Nofte
The following restrictions apply if the connections to OPC servers are cut.
» OPC server items can not be displayed.

» Groups can not be added or deleted.
» Group names can not be changed.
» Groups items can not be added or deleted.

IM WX1-04E 2-3
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2.2 Entering Environment Settings

Displaying the OPC Server List, Changing Settings, and Deleting Servers

Procedure

Displaying the OPC Server List

1. Click the Show or hide OPC server list button or choose View > OPC Server List
from the menu bar.

The OPC server list is displayed.

— Click a system number to display that system’s
window in the front of the screen

The show/hide OPC server list button
(714 GaLe0PC Configuratar - TakebishiModbusA[lystemMot] =IOl x|

Fle Fdt Exscuts View Window Help
HiE = =2 rsn 5@ 2
|82 TlakebishiModbus.1[System No 1]

O Dewice0dl 1
) Devicen02 1
O Device003 1
[ DeviceDO4 1
O Device00S 1

cut
Copy
Paste

Delete
Seleat All

Right to left Reading order
Shaw Unicode control characters

Insert Unicode contral characker b

Scan Interval

Ready [
I I I
Use button OPC server list Click a cell to select it for editing

Changing OPC Server Settings
2. Click the button in the Use column to turn the item ON or OFF (Use/Don’t use).
ON (blue)
OFF (gray)

Note
The Use button is active when running as a process or a service (see section 2.3). When
running as a process or service, you can not connect to OPC servers that are turned OFF.

3. Click the Scan Interval box and change the value.

4. Click the button in the Use Retry column to turn communication retry ON or OFF.
If turned ON, enter a Retry Interval.

ON (blue)
OFF (gray)
Retry interval setting range: 30—3600 seconds.

Deleting OPC Servers
2. Select the system number of the OPC server you wish to delete.
3. Click the Delete button.

The selected OPC server is deleted from the list.
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2.2 Entering Environment Settings

Displaying the OPC Server and Group Trees, and Editing Settings
1. You can add new OPC servers (see page 2-2, “Specifying an OPC Server”).

The OPC Server window is displayed in the GateOPCConfigurator screen, and
the OPC Server Tree and Group Tree are displayed to the left of that window.

Nofte
The device, group, tag, items, and other information specified for the connected OPC servers is
displayed.
Drag the mouse pointer on these locations to change column widths
1
e ot E—— RI=TE
OPC server tree Item ID ata Type ccess Right nit: escription
OPC group tree 1 Tael
£1 Tae2
1 Tae3

Displaying the OPC Server Tree

2. Click the Server Root folder located to the left of the OPC server window inside
the GateOPCConfigurator screen.

The server list is displayed.

Description
Boi

The following items are displayed.

Item ID: The added item IDs (see “Adding and Deleting Items”, 2 pages
down) are displayed.

Data Type: The type indicated by property ID1 (item canonical data type)
(see “Adding Items to Groups” in section 3.2 for the symbol).

Access Right: The access restrictions indicated by property ID5 (item access
rights).
OPC_READABLE Read
OPC_WRITEABLE Write
OPC_READABLE|OPC_WRITEABLE Read/Write
Unit: The string obtained from property ID100 (EU Unit).
If no property ID100 exists for the item, this cell is blank.
Description: The string obtained from property ID101 (item description).
If no property ID101 exists for the item, this cell is blank.

IM WX1-04E 2-5

ainpaosoud Bunesado ﬂ



2.2 Entering Environment Settings

Displaying OPC Groups

2. Click the Group Root folder located to the left of the OPC server dialog box inside
the GateOPCConfigurator screen.

The group list is displayed.

M3.1[System Mo 0] 1 o ] |
Group Mame Update Rate(ms... | Dead Bandi%:)

Group3

Eroups

The following Information is displayed in the list.

Group Name:

Specified names of each group

UpdateRate (ms): Display update interval (in units of msec)

Deadband (%):

Deadband expressed as a percentage

Changing OPC Group Settings

3. Click the cell of the item you wish to change then enter the new setting value.

Displaying and Changing Item Properties and Adding and Deleting Items
Displaying Item Properties
1. Click the group name located in the Group Root folder to the left of the OPC

server window.

The item properties are displayed in the OPC server window.

S Takebishi.FAM3.1[System No 0] N (=]
Spen Hght Lt
2 7 =

Ikem ID [
[ Devicel . Gro..,
[ Deveicel Gr...

Yalue

R =

I
Click a group to display item properties

Click to display the color setting dialog box

The following information is displayed.

Item ID:
Span Hight:

Span Low:

Tag Name:
Unit:

The specified item ID is displayed.
The setting range is -1E16 to 1E16.

The number of digits before the decimal point is determined by
the decimal place setting.

The initial value is that of the item’s property ID102 (High EU).
If this property ID has not been defined on the OPC server, the
value is set to 10.000.

The setting range is -1E16 to 1E16.

The number of digits before the decimal point is determined by
the decimal place setting.

The initial value is that of the item’s property ID103 (Low EU).
If this property ID has not been defined on the OPC server, the
value is set to -10.000.

Up to 16 alphanumeric characters can be input.

Up to 6 alphanumeric characters can be input. Enter only
English alphanumeric characters.

The default value is obtained from property ID100 (EU Unit).

2-6
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2.2 Entering Environment Settings

Dec Pos: Select a decimal place from 0 to 4.

Color: Select from the color selection dialog box.

Value: Displays the values during test execution. The number of digits
before the decimal point is determined by the decimal place
setting.

Changing Item Properties
2. Click a Span Hight, Span Low, Tag Name, or Unit cell, then change the setting.
3. If you click a Dec Pos cell a list appears. Make a selection from the list.

4. |If you click a Color cell, the Color setting dialog box appears. Select a color in the
dialog box.

Color )

i colors:

Lo
Ix

1717 TTHEEET

Define Custom Colors >3 |

Cancel |

Adding and Deleting Items
Nofte

If the item does not exist on the OPC server, it cannot be added or deleted.

e Adding and Deleting Items from the Menu Bar

1. Click the group name containing the item you wish to add or delete in the Group
Root folder on the left side of the OPC server window.

2. Choose Edit > Add Item or Delete.

¢ Adding and Deleting Items from the Group Name List

1. Right-click the group name containing the item you wish to add or delete in the
Group Root folder on the left side of the OPC server window.

The following menu is displayed.

2. Choose Add Item or Delete.
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2.2 Entering Environment Settings

Creating and Deleting Groups, and Changing Group Names

Procedure

Creating Groups
¢ Using a Tool Button or Menu Command to Create Groups

1. Click the Group creation button or choose Edit > Group Creation from the menu
bar.

Group creation button

The Group creation dialog box opens.

croup creation Y
Group Name Groupd
UpdateRate 500 maec
Dead Band ID-DDD %
[ ok | cemcer |

2. Enter settings for each item.

Group Name: Up to 30 alphanumeric characters can be input. Up to 50
groups can be created. However, fewer than 50 groups may
be allowed depending on the OPC server. The default value is
GroupN (where N indicates the order in which the group was
created). If the software fails to create the group, an error is
displayed. groups can not have the same name.

UpdateRate: The setting range depends on the connected OPC server. See
the specifications for the OPC server.

Deadband: You can enter the percent deadband, specifying when the
groups will be updated. The setting range depends on the
connected OPC server. See the specifications for the OPC
server.

3. Click OK.
The group is created.

¢ Using the Group List to Create Groups

1. Right-click the Group Root folder name located in the left side of the OPC server
dialog box.

The shortcut menu is displayed.

4 GateOPC Configurator - Takebishi.FAM3,

File Edit Execute WYiew ‘Window Help

EEEE Y

gE Takeb M3.1[System No 0]

2. Click Create New Group.
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2.2 Entering Environment Settings

Deleting Groups
¢ Using the Menu Bar to Delete Groups

1. Select the group you wish to delete.
2. Choose Edit > Delete from the menu bar.
The group is deleted.

¢ Using the Group List to Delete Groups

1. Right-click the group name located in the Group Root folder on the left side of the
OPC server window.

The shortcut menu is displayed.

0.000 | TAG
TaG
10.000 | TAG

2. Select Delete.

Changing a Group Name
¢ Using the Group List to Change a Group Name

1. Click a cell in the group list containing a group name.

Click to change the group name

— @& Group R

2. Change the name.

¢ Using the Group List to Change Group Names

1. Select a group name located in the Group Root folder to the left of the OPC server
window.

2. Click the selected group name.

The name can now be changed.

E= Takebishi.FAM3.1[System No 0]

Click to select for editing

3. Change the group name.
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2.2 Entering Environment Settings

Adding and Deleting Group Items
Note

These procedures are available only when connected with the OPC server.

Procedure

Adding Items
Up to 32 group items can be added.

e Using the Menu Bar to Add Items
1. Select the group to which you wish to add an item.
2. Choose Edit > Add Item.
The Add Item dialog box opens.

5
Item D : ||
ok | camcer |

3. Enter anitem ID.
4. Click OK.
The item is added.

¢ Using the Group List to Add Items

1. Right-click the group name located in the Group Root folder on the left side of the
OPC server window.

The following menu is displayed.

1[System No 0]

) Root
Add Ttem
Delete

wupd

2. Choose Add Item.
The Add Item window opens.

3. Follow steps 3 and 4 above under “Using the Menu Bar to Add ltems.”

Deleting Items
¢ Using the Menu to Delete Items
1. Right-click the item you wish to delete.
The following menu is displayed.

2. Select Delete.

¢ Using the Delete Key to Delete Items
1. Click the item ID you wish to delete.
2. Press the Delete key on the PC.

2-10 IM WX1-04E



2.2 Entering Environment Settings

Executing the Test

Procedure

Executing the Test

1. Click the group name located in the Group Root folder to the left of the OPC
server window.

The item properties are displayed in the right of the window.

Test execution button  Stop button

gﬁsj GateOPC Configurator - Takp 1[System No 0] ;

Tag Mame
0| TAG

2. Select the item ID for which you wish to perform the test.

3. Click the Test Execution button on the tool bar or choose Execute > Test from the
menu bar.

The test results are displayed in the value column of the item properties.

Stop button Test results are displayed here

%4 GateOPC Configurator - Takebishi.FAM3/1[System No 0] =10] =]

File Edit Execute WYiew ‘Window Help

£ Deveicel G,

|
|
Scrolls the screen

Stops the execution of the test

4. Click the Stop button on the tool bar or choose Execute > Stop from the menu
bar.
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2.3 Loading Data from the OPC Server and
Transferring It to DAQLOGGER or Remote
Monitor

By running the executable function, you can connect to and acquire data from the

OPC server, then transfer that data to DAQLOGGER or Remote Monitor via Ethernet.
GateOPC’s executable function acts as the client of a DAQLOGGER or Remote Monitor
that is running as the monitor server.

Procedure

Connecting to OPC Servers

1. Turn ON the OPC servers you wish to connect to in the Use column of the OPC
server list.

4 GateOPC Configurator - Takebishi.FAM3.1[System No 0] . -0l x|
File Edit Execute View ‘Window Help

| 2]

gE Takebishi.FAM3.1[System No 0] )
Update Rate{ms.., | Dead Bandi%:)

500 0,000

W Groups

2|l System No. OPC Server Mame Scan Intervalimsec)

=) Plon |1
1 L T akehizhi.

Ready ’_’_’_’_ 4

2. Connect to the OPC servers (see page 2-3, “Connecting/Disconnecting OPC
Servers”).

Entering TCP/IP Port Numbers for Monitor Servers
3. Choose File > Port number from the menu bar.

The PortSetting dialog box opens.

4 GateOPC Configurator - Také]
File Edit Execute Yiew ‘Windo

EEECIEIEEE

S Takebishi.FAM3.1[System

4. Enter the port number of the DAQLOGGER or Remote Monitor to which you wish
to connect.

Nofte
» See the DAQLOGGER and Remote Monitor user’'s manuals to obtain the correct port
numbers.
* Up to 16 GateOPCs can be connected simultaneously to DAQLOGGER or Remote Monitor.
+ DAQLOGGER's recorder model determination function identifies the system number only.
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2.3 Loading Data from the OPC Server and Transferring It to DAQLOGGER or Remote Monitor

Running as a Service or as a Process

5. Click the Service execution or Process execution button on the tool bar, or choose
Execute > Process or Service from the menu bar.

A dialog box appears asking you whether or not to save before execution.

6. Click OK.
Data is loaded at the specified scan interval. The data is displayed in the value
column.
Nofte
Execution occurs on OPC servers whose Use buttons are turned ON (blue) in the OPC server
list.
Service execution button
Process execution button Stop button

!;‘J-,ﬂ GateOPC Configurator - Takebishi.F.AM3. 1[System No 0]
File Edit Execute Miew ‘Window [Hel

Ready | | ’_’_’_’_ A

OPC server list Communication retry is performed on all systems
whose buttons are turned ON

All systems whose Use buttons are turned ON (blue) are run as a service or process

The GateOPC Information Software dialog box appears, and “Service” or “Process”
is displayed under Practice Status.

& GateOPC Information Soﬂ:wareﬁ P ] 4

File Help

___Process or Service is displayed
for the status
- Process
- Service
- Stop

Stopping a Service or Process

7. Click the Stop button on the tool bar or choose Execute > Stop from the menu
bar.

“Stop” appears as the practice status in the Status Display dialog box.

Note

» Service execution can only be specified by users with Administrator privileges.

» Services cannot be executed when using Windows Vista.

IM WX1-04E 2-13

ailnpasoud Buneisado ﬂ



2.4 \Viewing the Status of the Executable Function

Displaying the Connection Status

Procedure

1. Choose View > State Display.
The GateOPC Information Software dialog box opens, allowing you to see the
method under which the executable function may be running (as a process or as
a service), whether or not it is running, and with which PCs communications are
open.

— Displays the names
of connected clients

— Double-click to display
the Error Indicator dialog box
Displays the communications status with the client
Gray: Stopped
Red: Error
Green: Normal

Error Indicator =

See section 3.3 for error messages.

Note
» If a warning message is displayed (code Wxxxx), the lamp that displays the connection
status by color does not blink red.
*  When an error occurs and the lamp blinks red, the Error Indicator dialog box appears. If you
close the dialog box, the lamp turns green.
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2.5 Viewing Version Information

Procedure

1. Click the About button or choose Help > About from the menu bar.

|B IEN = A A= = A s !| ‘?|
About button

The Version dialog box opens.

GateOPC Configurator
i 1.

Copyright (C) 2003-2008 Yokogawa Electric Carporation
Software Japan
This Product is licensed to:

Company name

User name
License number

IM WX1-04E 2-15

ainpasoud Bunesado n



Chapter 3

Detailed Description of Functions

3.1

Overview

GateOPC performs COM or DCOM communications with OPC servers and acquires data
at regular intervals. Through the monitor server function, the acquired data is transferred
to DAQLOGGER or Remote Monitor via TCP/IP.

The following is a list of the features of each software function.

Environment Setting Functions

Environment setting functions are used to enter all environment settings required to run
the executable function, to run/stop the executable function, and to run the status display
function.

Specification of OPC Servers
Specification of the remote PC name
Selection/setting of the ProgID1
Connection to OPC Servers

Up to 16 OPC servers can be connected
Browsing OPC server items?

Display of item tree/list

Display of item properties
Creation/Deletion of Groups

Up to 50 groups can be created®

Entering of group names

Setting of acquisition interval for each group4
Setting of the percent deadband for each group4
Adding/Deleting of Group Items

Up to 32 items can be added to each group5
Setting of Item Properties

Setting of upper/lower span

Entering of tag names (up to 16 characters)
Entering of units (up to 6 characters)

Setting of the decimal places (0 to 4)
Setting of colors

Tests Execution (Data Acquisition)
Running/Stopping of the Executable Function
Running of the executable function as a service

(Services cannot be executed when using Windows Vista.)
Running of the executable function as a process

Stopping the executable function

Setting of the TCP/IP Port Number for the Monitor Server
Executable Function Status Display
1. The identifier for the OPC server (COM/DCOM server).
2. Possible if the IOPCBrowseServerAddressSpace interface (optional) is installed on the OPC
server.
3. The number of allowable groups may be less than 50 depending on the server.
4. The valid range depends on restrictions on the OPC server.
5. The number of items that can be added to groups may be less than 32 depending on the
server.

IM WX1-04E
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3.1 Overview

Executable Function
Features of the executable function are as follows:

* Running as a process and as a service is possible.
» Data is acquired from OPC servers at regular intervals.
* Runs as a monitor server if DAQLOGGER or Remote Monitor is the client.

Status Display Function
Features of the Status Display function are as follows:
» Executable Function Status Display
Practice status display (stopped, running as a service, running as a process).
The client connection status is displayed if DAQLOGGER or Remote Monitor is the
client.
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3.2 Detailed Description of Functions

OPC Server
GateOPC utilizes the OPC (OLE for process control) DA (data access) revision 2.0
server or later and COM/DCOM technology on the local machine or remote machine to
form a connection and acquire data.

Interfaces Used
The interfaces for the OPC server are defined as shown in the figures below.
OPC Server Object

IlUnknown

7

IOPCCommon Q—
loPCServer ()—

IOPCltemProperties Q— Standard

OPC Server

[lOPCServerPublicGroup] ()— Object
[IOPCBrowseServerAddressSpace] O—
[IPersistFile] (O)—
IConnectionPointContainer O—
N

OPC Group Object
IUnknown

7

IOPCltemMgt

IOPCGroupStateMgt

Standard
OPC Group
Object

[IOPCPublicGroupeStateMgt]
IOPCSvnclO

IOPCASvnclO2
IConnectionPointContainer

[IOPCASvncIO] old

PP

[I DataObject] old
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3.2 Detailed Description of Functions

The interfaces used by GateOPC are as follows:
* OPC Server Object
IOPCCommon
IOPCServer
IOPCltemProperties
IConnectionPointContainer
IOPCBrowseServerAddressSpace
» OPC Group Object
IOPCltemMgt
IOPCGroupStateMgt
IOPCSynclO

Nofte
According to OPC DA version 2 conventions IOPCBrowseServerAddressSpace is optional,
so GateOPC can run even if the OPC server does not have this interface. However, the OPC
server item browse function is not available without this interface.

Name of Remote PC

When connecting to the OPC server on a remote PC, you must specify the PC name. Up
to 80 characters can be entered for a PC name. In this case, the local PC must be able
to access the remote PC.

The conditions for connecting with an OPC server on a remote PC are as follows: For
details, see the user’s manual for the OPC server.

* That the client can use DCOM on the server side computer.

» That the server grants remote access

» That OPCENUM.EXE is running on the server side computer

Selecting/Setting the ProgID

An OPC server is a type of COM server, so a ProgID is used to identify individual OPC
servers.

GateOPC lists the ProgID of the OPC revision 2 server or later installed on the local PC
or Remote PC from the registry categories. The user must select one of the ProglDs from
the list to specify an OPC server. Furthermore, to search the ProglDs on the remote PC,
opcenum.exe must be running on the remote PC. If unable to search for ProglDs on the
remote PC, see the OPC server’s user’s manual.

Simultaneous Connections of Up to 16 OPC Servers

With GateOPC, you can connect with up to 16 OPC servers and acquire data. You can
also acquire data even when connecting to a combination of OPC servers residing on
both remote and local PCs.

GateOPC assigns a system number to each OPC server to be connected. When
connecting to GateOPC from DAQLOGGER or Remote Monitor and then acquiring data,
this number is used to identify each OPC server.

Interval at Which Data Is Acquired from the OPC Servers

You can specify the interval at which data GateOPC acquires data from the OPC servers.
The setting range is 0.5-3600 seconds. When connecting to multiple OPC servers, you
can specify different acquisition intervals for each.

Depending on the server performance and quality of connection, the data acquisition
interval may be insufficient, causing a data “Lack.” If this occurs, lengthen the acquisition
interval as needed.
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3.2 Detailed Description of Functions

Browsing OPC Server Iltems
This function not available if the IOPCBrowseServerAddressSpace
interface is not installed on the OPC server.
You can search through all items on the OPC servers and display them in a format similar
to the Windows explorer. You can display the layered structure of branch items, and all
leaf items on each layer. The data type, access rights (read/write), units, and details are
displayed for each leaf item.

Note

Units and details are optional properties, so they are not displayed if not installed on the OPC
servers.

Creating Groups/Group Names
Up to 50 groups can be created on GateOPC. These groups support OPC server group
objects. Therefore, fewer than 50 groups may be allowed depending on the OPC server
configuration.
You can assign a name to each group. GateOPC limits the number of characters in a
name to 30 characters. However, fewer than 30 characters may be allowed depending
on the OPC server.

Nofte

» Per OPC DA conventions, each group name must be unique. No two groups may have the
same name.

»  While the groups created here correspond to the OPC server settings as well as the group
settings when GateOPC is connected from Remote Monitor. These group settings are not
reflected on DAQLOGGER.

Group Data Update Interval
You can specify the data update interval for each group. The setting range depends on
the OPC servers. The interval is expressed in milliseconds.

Note

These settings correspond to the OPC server settings. See the OPC DA specifications for
details.

Group Percent Deadband
You can enter the percent deadband, specifying when the groups will be updated. The
setting range depends on the OPC servers. The deadband is expressed as a percentage.

Nofte

These settings correspond to the OPC server settings. See the OPC DA specifications for
details.
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3.2 Detailed Description of Functions

Adding Items to Groups
You can add an item to a group. GateOPC limits the number of characters to 32.
However, fewer than 32 may be allowed depending on the OPC server.

Note

These settings correspond to the OPC server settings and define GateOPC acquisition items.

An item may not be able to be added depending on its type. Data for each OPC DA item
are of the VARIANT type, but whether or not addition of items to that type and group is
allowed is as follows:

Data Type Description Group Add Allowed/Not Allowed
([YES]: Allowed, [NO]: Not Allowed)

VT_I2 Single precision integer YES

VT_l4 Double precision integer YES (or SHORT and LONG?)

VT_UI2 Single precision integer, no symbols YES

VT_Ul4 Double precision integer, no symbols YES

VT_INT Integer YES

VT_UINT Integer, no symbols YES

VT_R4 Single precision floating point number YES

VT_R8 Double precision floating point number YES

VT_DATE Day and time from 1899/12/30 NO

VT_BSTR Character string NO

VT_BOOL 0:FALSE —1:TRUE YES

Other NO

Setting Item Properties
You can specify the upper and lower limit of span, tag name (up to 16 characters), unit (up
to 6 characters), decimal place (0 to 4), and color for each item registered to groups.

Note

These settings do not involve the OPC server; they are used when sending data from GateOPC
to DAQLOGGER or Remote Monitor.

Colors are ignored by DAQLOGGER and Remote Monitor. Also, you can download tag names
using tag setting software.

A decimal place is defined as a significant digit behind the decimal point. The following is
an example of decimal place and data.

Actual data  Decimal places: 0 Decimal places: 1 Decimal places: 2 Decimal places: 3 Decimal places: 4
0.12345 0 0.1 0.12 0.123 0.1234
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3.2 Detailed Description of Functions

Acquiring Data at Fixed Intervals

The OPC server loads data from devices connected to the OPC server, stores it in the
data buffer (cache), and updates it at the interval set in the procedure on page 3-5 and
2-7, “Data Update Interval for Groups.” (Actually, the data is updated if the value set in
the procedure under “Percent Deadband for Groups” (page 3-5) changes to a larger
value. If the deadband is 0%, updating occurs each time.)

GateOPC loads the value stored in the internal buffer (cache) on the OPC server in
synch with the update interval specified in “Interval at Which Data is Acquired from the
OPC Server” (page 3-5 and 2-7).

The OPC server data loading operation and the GateOPC data loading operation when
the deadband is 0% is shown in the figure below.

Time

Device (PLC etc.)

Group data Group data Group data
update interval | update interval | update interval
OPC } Y } }
Data Access| Cached data | Cached data | Cached data | Cached data

Interval at which data| Interval at which data
is acquired from the | is acquired from the
y OPC servers y OPC servers y

GateOPC GateOPC internal buffer

Time of GateOPC internal data

Test Acquisition

The time of GateOPC internal data (timestamp), is the time on the PC on which
GateOPC is running at the time point at which GateOPC read data at synchronized 10
(IOPCSynclO).

If data was monitored by Remote Monitor, GateOPC’s data time is used.

If data was acquired from GateOPC by DAQLOGGER, it is the time at which data was
loaded by DAQLOGGER.

Using the configurator, you can connect to an OPC server and perform a test acquisition
using the synch IO (IOPSynclO) after registering new items to groups.

Communication Retry

If the OPC server is shut down for reasons such as the PC power supply becoming
disconnected, or being closed by the user, GateOPC retries communication with all OPC
servers for which Use Retry is turned ON in the GateOPCConfigurator dialog box. The
retry time is from 30 to 3600 seconds. At the point that communication is restored, the
OPC server is created, the necessary information is retrieved from OPC, and data is
acquired.

IM WX1-04E
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3.2 Detailed Description of Functions

Scan Mode

When connecting with DAQLOGGER to acquire OPC data, if the number of channels
in the GateOPC Configurator exceeds 1600, 1600 channels of data is sent to
DAQLOGGER, starting with the first channel of the instrument of the smallest system
number. Also, if an error occurs on an OPC during the first communication and
communication is restored by executing a communication retry, connection is possible
with that OPC in 1 scan mode without any channels being cut out.

Monitor Server Function

GateOPC takes data read in from devices and transfers the data to DAQLOGGER or
Remote Monitor.

The maximum number of DAQLOGGERSs or Remote Monitors that can be connected at
once is 16.

Executable Function Status Display

The status display function allows you to display the following status items for the

executable function.

* The executable function’s practice status (running as a service, running as a process)

* The name of PCs running DAQLOGGERSs and Remote Monitors connected to a
monitor server.

3-8
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3.3

Message and Corrective Actions

Error
No. Message Corrective Actions
E211 Cannot write to file. Check if the disk capacity is sufficient or if the file systems is
normal.
E212 Cannot read file. Check if the file exists and is supported by the software or if the file
system is normal.
E213 Cannot open file. Check if the file exists and is supported by the software or if the file
system is normal
E401 Communication error. Check if the recorder connected for communication is powered on
and if the cable is properly connected. Also check the following
items according the communication type.
* For Ethernet
Check if address settings are correct; the TCP/IP protocol is
installed in Windows; the Ethernet card is properly installed.
* For RS-232 and RS-422
Check if the baud rate settings match; the port (COM1 to COM9)
settings match, the address settings are correct (RS-422); the
serial port of the PC is active and the appropriate cable is being
used.
E402 Communication timeout. -
E403 Cannot open a communication port. Same as E401.
E501 Invalid license number. Install the software again.
Please reinstall the software.
E1010 Execution of a process failed. Check whether an executable function exists, or whether its files
are damaged. If this error appears frequently, reinstall the software.
E1011 Execution of a service failed. Check whether an executable function exists, or whether its files
are damaged. If this error appears frequently, reinstall the software.
E1301 Cannot connect OPC server. Check whether the OPC server is available.
E1302 Execution of status display function failed. Check whether an executable function exists, or whether its files
are damaged. If this error appears frequently, reinstall the software.
E1303 Failed to create group. An error was returned from the OPC server when creating a group.
Check the status of the OPC server.
E1304 Failed to create item. An error was returned from the OPC server when creating an item.
Check the status of the OPC server.
Warning
No. Message Corrective Actions
E1401 Computer not found. Check whether the specified computer exists on the network, or
whether the network is functioning normally.
Message
No. Message
M1201 Model determination was successful.
M1210 Setting changes saved before execution.
M1501 Delete server?
M1502 Delete selected item?
M1503 Delete selected group?
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3.3 Message and Corrective Actions

Executable Function Messages

No. Message Corrective Actions

WI[631] Data Lack Reduce the number of acquired data points or connected
instruments, or lengthen the scan interval.

E[637] Cannot open communication = Same as E401.

E[674] Communication error Same as E401.

E[675] Communication time out Same as E401.

E[750] Cannot create OPC server Same as E1301.

E[751] Cannot create Interface OPC  Check whether the OPC server is functioning correctly.

E[752] Cannot create Interface Check whether the OPC server is functioning correctly.

Shutdown

E[753] Cannot create Group Same as E1301.

E[754] Cannot create Item Same as E1304.

E[755] Shutdown OPC Server The OPC server was shut down during communication. Check the
status of the OPC server.

1[606] Recovery Communication Connection recovered.
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